Actualización acumulativa para Microsoft Internet Explorer

SeguridadVirus

Uno de los boletines de seguridad lanzados por Microsoft solventa ocho vulnerabilidades del navegador de la compañía.

Dentro del conjunto de boletines de agosto publicado esta semana por Microsoft se encuentra el anuncio (en el boletín MS06-042) de una actualización acumulativa para Internet Explorer, que además solventa un total de ocho nuevas vulnerabilidades descubiertas en las versiones 5.01 y 6 del navegador.

Las vulnerabilidades corregidas son las siguientes:

– Revelación de información por problemas con redirección de dominios: se ha descubierto una vulnerabilidad de revelación de información debida a la forma en la que trata los redireccionamientos. Un atacante puede explotar esta vulnerabilidad construyendo una página web, que si es visitada por la víctima, permitiría al usuario malicioso leer datos de archivos de una página web en otro dominio del navegador. Esta otra página debe usar codificación gzip u otro tipo de compresión soportada por Explorer para que la explotación se realice con éxito. Esta otra página debe estar además cacheada en el cliente de la víctima.

– Corrupción de memoria por error en posicionamiento de HTML: se ha descubierto una vulnerabilidad de ejecución remota de código debido a la forma en la que Internet Explorer interpreta HTML con ciertas combinaciones de posicionamiento de disposición. Un atacante puede explotar la vulnerabilidad construyendo una página maliciosa que provocaría la ejecución remota de código si es visualizada por la víctima.

– Corrupción de memoria en tratamiento de CSS: se ha descubierto una vulnerabilidad de ejecución de código remoto debido a la forma en la que Internet Explorer trata los CSS (Cascading Style Sheets) encadenados. Un atacante puede explotar la vulnerabilidad construyendo una página web maliciosa que si es visitada por la víctima, provocaría en el sistema de la víctima la ejecución de código arbitrario.

– Corrupción de memoria en interpretación de HTML: se ha descubierto una vulnerabilidad de ejecución remota de código arbitrario debida a la forma en la que Internet Explorer interpreta el HTML con ciertas combinaciones de composición. Un atacante puede explotar la vulnerabilidad construyendo una página web maliciosa que, si es visitada por la víctima, provocaría la ejecución remota de código en el sistema de esta.

– Corrupción de memoria por instanciación de objetos COM: se ha descubierto una vulnerabilidad de ejecución remota de código debido a la forma en la que Internet Explorer instancia objetos COM que no fueron diseñados para ser instanciados por el mismo. Un atacante puede explotar la vulnerabilidad construyendo una página web maliciosa que provocaría la ejecución de código arbitrario si es visualizada por la víctima.

– Vulnerabilidad cross-domain en elemento fuente: se ha descubierto una vulnerabilidad en Internet Explorer debido a la forma en la que trata las redirecciones que puede ser explotada para acceder a información o para realizar ejecución remota de código. Un atacante puede explotar la vulnerabilidad construyendo una página maliciosa que si es visitada por la víctima, le permitiría leer archivos de una página web en un dominio diferente de Internet Explorer. En el caso de Windows 2000 SP4 y Windows XP SP1, el atacante puede explotar la vulnerabilidad para provocar la ejecución remota de código si la víctima visualiza la página maliciosa.

– Revelación de información de posición de ventana: se ha descubierto una vulnerabilidad de revelación de información debido a que un script puede persistir entre distintas navegaciones en Internet Explorer para conseguir así acceso a la localización de una ventana en otro dominio o zona de Internet Explorer. Un atacante puede explotar la vulnerabilidad construyendo una página web maliciosa que revelaría dicha información si la víctima la visita.

– Inyección de comandos a servidores FTP: se ha detectado una vulnerabilidad de escalada de privilegios debida a la forma en la que Internet Explorer trata ciertos enlaces a FTP que contiene caracteres de salto de línea. Un atacante puede explotar esta vulnerabilidad construyendo una página que permitiría al atacante mandar comandos a un servidor FTP si el usuario pulsa sobre el enlace FTP. Si el atacante realiza el ataque con éxito, podrá enviar comandos al servidor como si fuera el usuario víctima.

Actualice los sistemas afectados mediante Windows Update.

Leer la biografía del autor  Ocultar la biografía del autor