Actualización de seguridad de Apache 2.0.*

CloudGestión Cloud

La fundación Apache acaba de publicar la versión 2.0.47 de su servidor, que soluciona varios problemas de seguridad importantes.

Apache es el servidor web más popular del mundo, disponible en código fuente y para infinidad de plataformas, incluyendo UNIX, Microsoft Windows, OS/2 y Novell NetWare.

Además de solucionar numerosos bugs, los problemas de seguridad eliminados son:

-Cuando en un directorio se configura un criptosistema más “fuerte” que el configurado por defecto, bajo ciertas secuencias de renegociación y dependiendo de la configuración del servidor, es posible que se seleccione incorrectamente el criptosistema más “débil”.

-Debido a un bug en “prefork MPM” (uno de los modelos de trabajo de Apache), es posible crear una situación de denegación de servicio temporal provocando ciertos errores en la llamada al sistema “accept()”.

-Ataque de denegación de servicio en el módulo de proxy FTP, si el destino es IPv6 y el módulo es incapaz de crear el “socket”.

-Posibilidad de ataque DoS (Denegación de Servicio) debido a un bucle infinito por redirecciones internas y subpeticiones anidadas.

Se recomienda a todos los usuarios de Apache 2.0.* que actualicen a la versión 2.0.47. Estos problemas de seguridad no afectan a la serie 1.3.* del servidor.

Leer la biografía del autor  Ocultar la biografía del autor