Actualización de seguridad de Ethereal

CortafuegosSeguridad

Las versiones no actualizadas de ethereal adolecen de varias vulnerabilidades que pueden permitir la caída del proceso e, incluso, la ejecución de código arbitrario.

Ethereal es un analizador de protocolos de red gratuito para entornos Unix y Windows. Permite examinar datos directamente ‘esnifándolos’ de la red o de un archivo de captura, y posee diversas utilidades para hacer más cómodo el trabajo con estos datos, como un potente lenguaje de filtrado de visualización.

Las versiones no actualizadas de Ethereal contienen las siguientes vulnerabilidades:

– Un error de programación en las rutinas de disección de DICOM permite matar el proceso ethereal. Bajo ciertas circunstancias puede permitir la ejecución de código arbitrario.

– Un “timestamp” RTP inválido puede provocar el cuelgue de Ethereal, generando un fichero temporal de gran tamaño, potencialmente llenando el disco duro.

– El diseccionador HTTP puede liberar varias veces el mismo bloque de memoria, provocando la caída del ethereal. Bajo ciertas condiciones puede permitir la ejecución de código arbitrario.

– Un paquete SMB mal formateado puede provocar el cuelgue de ethereal, consumiendo todo el tiempo de CPU disponible.

Hispasec recomienda actualizar con urgencia a la versión 0.10.8 de Ethereal.

Leer la biografía del autor  Ocultar la biografía del autor