Actualización de seguridad de MySQL

SeguridadVirus

Las versiones de MySQL anteriores a la 5.0.21 contienen varias vulnerabilidades que permiten provocar la caída del servicio MySQL o el acceso a información potencialmente comprometedora.

MySQL es un servidor de bases de datos SQL, “open source”, muy difundido en el mundo Linux.

Las versiones de MySQL anteriores a la 5.0.21 contienen las siguientes vulnerabilidades:

* Un atacante malicioso puede consumir toda la memoria del servidor mediante el envío de transacciones sin completarlas. Las versiones previas de MySQL no imponen ningún límite en el número de transacciones pendientes, lo que puede llevar a que se consuma toda la memoria disponible y provocar la caída del servicio. A partir de la versión 5.0.21 existe una variable de configuración para fijar un valor máximo.

* Un atacante malicioso puede enviar una petición de “login” o “COM_TABLE_DUMP” inválido, especialmente formateado, y leer así memoria no inicializada. Dicha memoria puede contener datos arbitrarios, potencialmente delicados o valiosos.

* Un atacante malicioso puede enviar un comando “COM_TABLE_DUMP” especialmente formateado y ejecutar código arbitrario en el servidor mediante un desbordamiento de búfer.

Hispasec recomienda a todos los administradores de instalaciones MySQL 5.0 que actualicen cuanto antes a la versión 5.0.21.

Leer la biografía del autor  Ocultar la biografía del autor