Actualización de seguridad para cURL

SeguridadVirus

Las versiones de “cURL” no actualizadas contienen una vulnerabilidad que permite que un atacante ejecute código arbitrario bajo los privilegios del proceso que utilice “cURL”.

“cURL” es una librería y herramienta para descargar ficheros por Gopher, FTP, FTPs, HTTP, HTTPs, telnet, DICT, FILE y LDAP.

El problema reside en la rutina de gestión de URLs. Si un atacante proporciona a la librería una URL excesivamente larga, puede provocar un desbordamiendo de búfer y la ejecución de código arbitrario con los privilegios del proceso atacado.

El ataque puede desarrollarse de dos maneras posibles, compatibles, por lo que pueden utilizarse de forma simultánea. Aunque el desbordamiento de búfer es muy limitado y parece difícil de explotar para provocar la ejecución de código arbitrario, no debe descartarse. Por ello, Hispasec recomienda a todos los usuarios de “cURL” que actualicen cuanto antes a la versión 7.15.1, sobre todo si utilizan plataformas “little endian”, como x86.

La vulnerabilidad afecta, por supuesto, a los programas que utilicen la librería “libcurl”. Los programas enlazados de forma dinámica con la librería deben ser reiniciados, para que empleen la versión correcta. Los programas que se enlacen de forma estática deben ser recompilados/reenlazados.

Las versiones afectadas son de la 7.11.2 a la 7.15.0, inclusive.

Leer la biografía del autor  Ocultar la biografía del autor