Actualización del kernel de Linux por vulnerabilidades

SeguridadVirus

Se han descubierto diversas vulnerabilidades en los kernel 2.4 y 2.6 de Linux.

Se han descubierto diversas vulnerabilidades en los kernel 2.4 y 2.6 de Linux que puede ser explotado por usuarios maliciosos para acceder a información sensible, provocar denegaciones de servicio, realizar escaladas de privilegios y, en ultima instancia, comprometer un sistema afectado.

La primera se debe a algunos errores sin especificar en el componente que trata el sistema de archivos ISO9660, incluyendo las extensiones Rock Ridge y Juliet. Esto puede ser explotado con un sistema de archivos especialmente creado a tal efecto para provocar denegaciones de servicio o, potencialmente, corromper zonas de memoria y con ello ejecutar código arbitrario.

Otro problema detectado se debe a un error de tratamiento de signos en la función ‘bluez_sock_create()’ cuando se crean sockets bluetooth. Esta circunstancia podría ser explotada para conseguir privilegios de root en un sistema vulnerable.

Otro error detectado es una fuga de información en ext2 cuando se crean nuevos directorios. Este problema puede explotarse para acceder a memoria de kernel.

Finalmente, se ha detectado un error en load_elf_library que puede ser explotado para provocar denegaciones de servicio.

Se recomienda actualizar a la versión 2.6.11.6, disponible en la siguiente dirección: http://kernel.org

También se han corregido las vulnerabilidades en la versión 2.4.30-rc2.

Leer la biografía del autor  Ocultar la biografía del autor