Denegación de servicio en dispositivos Cisco a través de paquetes DNS

CortafuegosSeguridad

Se ha descubierto una vulnerabilidad en diversos productos de Cisco que permitirían a usuarios maliciosos provocar denegaciones de servicio en dichos dispositivos.

La vulnerabilidad se debe a un error de la implementación DNS a la hora de descomprimir mensajes DNS. Esta circunstancia puede explotarse por un atacante enviando un paquete DNS que contenga información no válida en la sección comprimida. El uso con éxito de esta vulnerabilidad provocaría el funcionamiento anormal del dispositivo, o incluso la caída de la aplicación.

La vulnerabilidad afecta a los siguientes productos:

Cisco IP Phones 7902/7905/7912

Cisco ATA (Analog Telephone Adaptor) 186/188

Cisco Unity Express

Los siguientes dispositivos ACNS también se ven afectados:

Cisco 500 Series Content Engines

Cisco 7300 Series Content Engines

Cisco Content Routers 4400 series

Cisco Content Distribution Manager 4600 series

Cisco Content Engine Module para Integrated Service Routers Cisco series 2600, 2800, 3600, 3700, y 3800

Los usuarios que se vean afectados por este problema podrán actualizarse en:

http://www.cisco.com/public/sw-center

La descripción de parches según versión de producto afectado está disponible en el patch matrix del aviso de la compañía:

http://www.cisco.com/warp/public/707/cisco-sn-20050524-dns.shtml#software

Leer la biografía del autor  Ocultar la biografía del autor