Denegación de servicio en Snort 2.4.0

SeguridadVirus

Se ha descubierto una vulnerabilidad en Snort 2.4.0 que puede ser explotada por usuarios maliciosos para provocar denegaciones de servicio.

La vulnerabilidad se debe al tratamiento incorrecto de punteros en la función ‘PrintTcpOptions()’, localizada en snort-2.4.0/src/log.c. Esta circunstancia puede ser explotada para tirar Snort con paquetes TCP/IP con la opción TCP SACK maliciosamente construida. La explotación con éxito requiere que Snort se esté ejecutando en modo verbose.

Si bien el problema se ha confirmado en la versión 2.4.0, no se descarta que versiones anteriores puedan verse también afectadas.

Existe una corrección disponible en http://www.snort.org/pub-bin/snapshots.cgi y que será incluida en la futura versión 2.4.1.

Leer la biografía del autor  Ocultar la biografía del autor