Desbordamiento de búfer en diversos productos F-Secure

SeguridadVirus

Se ha descubierto una vulnerabilidad en diversos productos de F-Secure que puede ser explotada por usuarios maliciosos para comprometer la seguridad de un sistema que use un software afectado por ella.

La vulnerabilidad se debe a un error en el tratamiento del tamaño de variables dentro de la funcionalidad de análisis antivirus, concretamente a la hora de tratar con archivos ARJ. Esta circunstancia puede aprovecharse para provocar un desbordamiento de búfer y con ello la ejecución remota de código arbitrario.

La lista de productos afectados por la vulnerabilidad es la siguiente:

F-Secure Anti-Virus para Workstation versión 5.43 y anteriores

F-Secure Anti-Virus para Windows Servers versión 5.50 y anteriores

F-Secure Anti-Virus para Citrix Servers versión 5.50

F-Secure Anti-Virus para MIMEsweeper versión 5.51 y anteriores

F-Secure Anti-Virus Client Security versión 5.55 y anteriores

F-Secure Anti-Virus para MS Exchange versión 6.31 y anteriores

F-Secure Internet Gatekeeper versión 6.41 y anteriores

F-Secure Anti-Virus para Firewalls versión 6.20 y anteriores

F-Secure Internet Security 2004 y 2005

F-Secure Anti-Virus 2004 y 2005

Soluciones basadas en F-Secure Personal Express versión 5.10 y anteriores

F-Secure Anti-Virus para Linux Workstations versión 4.52 y anteriores

F-Secure Anti-Virus para Linux Servers versión 4.61 y anteriores

F-Secure Anti-Virus para Linux Gateways version 4.61 y anteriores

F-Secure Anti-Virus para Samba Servers versión 4.60 y anteriores

F-Secure Anti-Virus Linux Client Security 5.01 y anteriores

F-Secure Anti-Virus Linux Server Security 5.01 y anteriores

F-Secure Internet Gatekeeper para Linux 2.06

Leer la biografía del autor  Ocultar la biografía del autor