Desbordamiento de búffer en Squid 2.5.* y 3.*

SeguridadVirus

Se ha descubierto una vulnerabilidad en Squid que puede ser explotada por usuarios maliciosos para comprometer un sistema.

Squid es un proxy cache Web clásico, con gran cantidad de funcionalidades (como soporte para HTTP, FTP, trabajo con SSL, jerarquías de caché, etc.).

El problema que provoca esta vulnerabilidad consiste en un error de comprobación de tamaños de variables en la función ntlm_check_auth(). Esta función es utilizada durante el proceso de soporte de autenticación NTLM.

NTLM es un protocolo de autenticación utilizado en varios protocolos de red de Microsoft. Usado originalmente para la negociación de DCE/RPC seguros, NTML también es usado en productos de dicha compañía como mecanismo integrado de validación única.

Esa falta de comprobación de tamaños puede aprovecharse enviando una clave de acceso muy larga creada a tal efecto, lo que provoca un desbordamiento de búfer basado en heap y por tanto la posibilidad de ejecución de código arbitrario. Para que esto pueda darse, Squid tiene que haber sido compilado para utilizar ese tipo de soporte de autenticación. Se ha confirmado que se da en las versiones 2.5.*-STABLE y 3.*-PRE.

Se recomienda aplicar el parche de actualización, disponible en la siguiente dirección.http://www.squid-cache.org/~wessels/patch/libntlmssp.c.patch

Otra solución pasa por recompilar Squid sin la opción que presenta la vulnerabilidad.

Leer la biografía del autor  Ocultar la biografía del autor