Ejecución de código en múltiples dispositivos inalámbricos a través del controlador Broadcom NIDS

SeguridadVirus

El controlador de dispositivo inalámbrico Broadcom, BCMWL5.SYS, esvulnerable a un desbordamiento de memoria intermedia basado en pilaque permite la ejecución de código arbitrario en modo núcleo. El fallose debe a manejo inseguro de respuestas sonda 802.11 que contengan uncampo SSID muy largo.

El problema se considera bastante grave por varias razones. La primera es que el controlador BCMWL5.SYS se proporciona unido a los sistemas de muchos fabricantes. Broadcom tiene acuerdos con diferentes compañías que incorporan sus chipsets en los controladores inalámbricos. Viene integrado por ejemplo en ordenadores Dell, HP o tarjetas Linksys y todos comparten básicamente el mismo controlador.

La segunda razón es que puede ser aprovechado sin interacción por parte

del usuario. Se está en riesgo si la tarjeta inalámbrica con controladores vulnerables permanece activa en cualquier lugar público y

alguien emite información. Este sería recogido por la tarjeta y podría permitir el aprovechamiento de la vulnerabilidad. Por ejemplo, en Windows, el escáner integrado que permite descubrir nuevas redes lo volvería vulnerable si posee una tarjeta funcionando con estos controladores.

La tercera razón por la que puede considerarse especialmente peligroso es que ya existe un exploit público en la versión de desarrollo de

Metasploit Framework.

La cuarta razón es que es complicado delimitar la responsabilidad de publicar un parche. No está totalmente definida. Ni siquiera

organizaciones ajenas pueden acudir en su ayuda. El grupo ZERT, (Zero Day Emergency Response Team) cuyo objetivo es el de programar parches para solventar problemas de seguridad de tipo “0 day” siempre que su

gravedad lo requiera, ha publicado una nota donde explica las razones por las que no puede crear una actualización extraoficial en este caso.

Sería impráctico crear un parche para cada controlador de cada fabricante y tampoco sería posible programar uno genérico efectivo.

Para dispositivos Linksys, como excepción por ahora, ya se ha programado una solución disponible en su página web.

La versión comprobada vulnerable es la 3.50.21.10 del controlador BCMWL5.SYS en Windows. Usuarios de Linux y FreeBSD deberían asegurarse de que no están usando el controlador vulnerable a través de la

herramienta ndiswrapper. En general, se recomienda que todos los usuarios se pongan en contacto con los fabricantes de sus dispositivos inalámbricos, comprobar si sus controladores son vulnerables y aplicar

soluciones específicas.

Leer la biografía del autor  Ocultar la biografía del autor