Elevación de privilegios en varias versiones de Java Runtime Environment

SeguridadVirus

Se han encontrado siete vulnerabilidades no especificadas en el uso de APIs “reflection” en Java Runtime Environment por las que un applet no confiable podría elevar sus privilegios.

Por ejemplo un applet podría darse a sí mismo permisos para leer o escribir ficheros locales o ejecutar aplicaciones en local accesibles por el usuario que ejecuta el applet.

El primer fallo puede ocurrir en las siguientes versiones para Windows, Solaris y Linux:

JDK y JRE 5.0 Update 3 y anteriores.

SDK y JRE 1.4.2_08 y anteriores.

SDK y JRE 1.3.1_16 y anteriores

El segundo y tercer fallo pueden ocurrir en las siguientes versiones para Windows, Solaris y Linux:

JDK y JRE 5.0 Update 4 y anteriores.

SDK y JRE 1.4.2_09 y anteriores.

SDK y JRE 1.3.x no están afectados por estos dos fallos.

El cuarto fallo puede ocurrir en las siguientes versiones para Windows, Solaris y Linux:

JDK y JRE 5.0 Update 4 y anteriores.

SDK y JRE 1.4.x y 1.3.x no se ven afectados por este fallo.

El quinto, sexto y séptimo fallo pueden ocurrir en las siguientes versiones para Windows, Solaris y Linux:

JDK y JRE 5.0 Update 5 y anteriores.

SDK y JRE 1.4.x and 1.3.x no se ven afectados por estos tres fallos.

La primera vulnerabilidad está solventada en:

JDK y JRE 5.0 Update 4 y posteriores.

SDK y JRE 1.4.2_09 y posteriores.

SDK y JRE 1.3.1_17 y posteriores.

La segunda y tercera vulnerabilidades están solventadas en:

JDK and JRE 5.0 Update 5 y posteriores.

SDK y JRE 1.4.2_10 y posteriores.

La cuarta vulnerabilidad está solventada en:

JDK y JRE 5.0 Update 5 y posteriores.

La quinta, sexta y séptima vulnerabilidades están solventadas en:

JDK y JRE 5.0 Update 6 y posteriores.

J2SE 5.0 se puede descargar desde:

http://java.sun.com/j2se/1.5.0/download.jsp

http://java.com

J2SE 1.4.2 se puede descargar desde:

http://java.sun.com/j2se/1.4.2/download.html

Leer la biografía del autor  Ocultar la biografía del autor