Escalada de directorios en WinAce 2.5

SeguridadVirus

Se ha descubierto una vulnerabilidad en la versión 2.5 de WinAce que podría ser explotada por un atacante para comprometer un sistema que utilice dicho software.

WinAce es un completo gestor de archivos comprimidos que soporta gran cantidad de formatos, aporta muchas funcionalidades de información y organización de archivos y se integra fácilmente en el entorno Windows.

El problema detectado es de escalada de directorios, y se debe a un error de validación de entradas a la hora de descomprimir archivos en formato GZIP (.gz) o ZIP (.zip).

Utilizando secuencias de cadenas clásicas de escalada de directorios (‘../’), un atacante podría aprovechar esta circunstancia para extraer archivos en localizaciones arbitrarias fuera del directorio especificado para realizar dicha operación.

Si bien la vulnerabilidad ha sido confirmada en la versión 2.5, no se descarta que pueda afectar a otras.

A la espera de un parche de actualización, se puede optar o bien por usarlo sólo con archivos de fuentes de total confianza, cesar el uso de este software o actualizar a la versión 2.6, que actualmente se encuentra en fase Beta 4.

Leer la biografía del autor  Ocultar la biografía del autor