Múltiples vulnerabilidades en gestores IOCTL del Kernel Linux

SeguridadVirus

Se han detectado múltiples vulnerabilidades en la rama 2.6.x del Kernel Linux debidas a errores de diseño en los gestores ioctl de dispositivos tipo “raw” y los dispositivos de bloque pktcdvd, que los hacen propensos a corrupciones de memoria.

Los gestores ioctl realizan una amplia variedad de control específico de dispositivos en ficheros de dispositivo especiales. La función ioctl() está orientada al control de parámetros de ficheros especiales, como sockets, los dispositivos de consola y los dispositivos de comunicación por puertos.

Estas vulnerabilidades están ocasionadas por una falta de comprobaciones en los valores de los argumentos que se suministran a las funciones de los gestores ‘raw_ioctl()’ y ‘pkt_ioctl()’, lo que podría desencadenar en la ejecución de código arbitrario en el contexto del núcleo comprometido.

Un atacante local podría explotar estas vulnerabilidades para elevar sus privilegios en el sistema. La elevación de privilegios requiere que el usuario tenga permisos de lectura en el dispositivo de bloque afectado, con lo que la gravedad de la falla es por tanto menor.

Para corregir este comportamiento erróneo , desde Hispasec recomendamos a los administradores actualizar a la versión 2.6.11.10 del Kernel Linux.

Leer la biografía del autor  Ocultar la biografía del autor