Múltiples vulnerabilidades en MIT Kerberos V5

SeguridadVirus

Se han descubierto múltiples vulnerabilidades en kerberos V5 que podrían ser explotadas para provocar denegaciones de servicio o incluso comprometer un sistema vulnerable.

Kerberos es un protocolo de autentificación que permite centralizar en un servidor la gestión de accesos a toda una red de grandes proporciones. Básicamente, un cliente se autentifica ante el servidor de autentificación, y éste le proporciona “tickets” para que pueda acceder a los servicios de red como impresoras o discos compartidos.

Se han detectado varios errores de liberación doble de memoria en el código de limpieza del KDC (Key Distribution Center) y en librerías cliente. El problema se produce al liberar la memoria heap de forma insegura, lo que puede provocar que se libere el mismo espacio dos veces y permitir a un usuario sin autenticar ejecutar código en un sistema afectado. Esta vulnerabilidad afecta a la versión 1.3.4 y anteriores.

También existen errores de liberación doble en la función ‘krb5_rd_cred()’ que de igual forma permitirían la ejecución de código en un sistema vulnerable. Esto puede ser explotado usando los servicios que usan dicha función, como krshd, klogind y telnetd. Esta vulnerabilidad afecta a la versión 1.3.1 y anteriores.

Otro error de doble liberación en krb524d puede permitir la ejecución de código arbitrario, y afecta a las versiones de la 1.2.8 a la 1.3.4.

Por último, un error en el decodificador de ASN.1 puede ser explotado por usuarios sin autentificar para provocar una denegación de servicio al hacer que entren en un bucle sin fin al utilizar una codificación BER especialmente construida a tal efecto. Esta vulnerabilidad afecta a las versiones de la 1.2.2 a la 1.3.4.

Se recomienda actualizar a la versión 1.3.5 cuando esté disponible en la siguiente dirección:

http://web.mit.edu/kerberos/dist/index.html

Leer la biografía del autor  Ocultar la biografía del autor