Varias vulnerabilidades en Asterisk 1.x

SeguridadVirus

Se han descubierto varias vulnerabilidades en Asterisk que podrían ser aprovechadas por un atacante para causar una denegación de servicios o comprometer un sistema vulnerable.

Asterisk es una aplicación de código abierto de una central telefónica (PBX). Como cualquier PBX, se puede conectar un número determinado de teléfonos para hacer llamadas entre sí e incluso conectar a un proveedor de VoIP. Asterisk incluye interesantes características: buzón de voz, conferencias, IVR, distribución automática de llamadas, y otras muchas más. Asterisk funciona en plataformas Linux, BSD, MacOSX, Solaris y Microsoft Windows.

La primera vulnerabilidad se debe a dos errores de límite en el parser T.38 SDP del canal SIP cuando procesa los parámetros SDP T38FaxRateManagement o T38FaxUdpEC en la función process_sdp() en Chan_sip.c. Para que un atacante pudiera aprovechar esta vulnerabilidad, la configuración de t38_udptl debería estar en Yes. Esta vulnerabilidad afecta a la versión 1.4.x anteriores a 1.4.3

Otra vulnerabilidad se debe a un error en la deferencia de un puntero NULL en la autenticación de Asterisk Remote Management Interface. Un atacante podría aprovechar esto para provocar que el servicio dejase de funcionar. Para que un atacante pudiera aprovechar esta vulnerabilidad es necesario que la interfaz de administración esté habilitada y que exista un usuario sin contraseña configurado en manager.conf. Esta vulnerabilidad afecta a la versión 1.2.x anterior a la 1.2.18 y a la 1.4.x anterior a la 1.4.3.

Se recomienda la actualización a la versión 1.4.3 disponibles en: ftp://ftp.digium.com/pub/telephony/asterisk

Leer la biografía del autor  Ocultar la biografía del autor