Varios fallos de desbordamiento de memoria en xpdf

SeguridadVirus

Se han descubierto algunas vulnerabilidades en xpdf que pueden ser aprovechadas por atacantes con impacto desconocido.

Xpdf es un visualizador de archivos PDF open-source, de amplio uso en diversas distribuciones Linux (Red Hat, SuSE, Fedora, Debian, Gentoo, etc), además de otros entornos como FreeBSD u OpenBSD.

Los fallos son causados por varios desbordamientos en “JBIG2Stream.cc”, “Stream.cc” y “JPXStream.cc” y pueden ser aprovechados para provocar desbordamientos de memoria y la ejecución de código arbitrario en sistemas afectados.

El fallo afecta a la versión 3.01 aunque otras versiones podrían verse afectadas. Como contramedida se recomienda restringir el uso de ficheros PDF que provengan de fuentes confiables.

Leer la biografía del autor  Ocultar la biografía del autor