Vulnerabilidad en Cisco Collaboration Server

SeguridadVirus

Las versiones de Cisco Collaboration Server (CCS) anteriores a la 5.0 se distribuyen con versiones de ServletExec que son vulnerables a ataques por los que un usuario no autorizado podrá subir cualquier archivo y conseguir privilegios administrativos.

Cisco Collaboration Server utiliza el subcomponente ServletExec proporcionado por New Atlanta para Microsoft Windows 2000 y Windows NT. Las versiones de ServletExec anteriores a la SE 3.0E permiten que un atacante suba archivos al servidor web y ejecutarlos. Se recomienda a los usuarios actualizar a CCS 5.x que incluye ServletExec 4.1, descargar el script automatizado para CCS 4.x, o realizar la actualización de forma manual.

Los usuarios de Cisco Collaboration Server 4.x pueden parchear el software con el script disponible en http://www.cisco.com/cgi-bin/tablebuild.pl/ccs40, o actualizarse a CCS 5.x. Los usuarios de CCS 3.x (que incluye ServletExec 2.2) deberán eliminar la vulnerabilidad de forma manual. Para ello, hay que detener Internet Information Server (IIS), abrir el archivo ServletExec22.jar (del directorio C:Program Filesnew atlantaservletexec ISAPIlib) con alguna utilidad de descompresión (Winzip o similar) y eliminar UploadServlet.class. Grabar ServletExec22.jar sin el componente vulnerable en su localización original y reiniciar IIS.

Tras actualizar ServletExec se elimina el componente UploadServlet que es el que provoca la vulnerabilidad del archivo ServletExec30.jar pero no altera el número de versión. La mejor forma de comprobar si CCS es vulnerable es intentar cargar la URL cuando CCS esté en ejecución. Si el intento termina en un NullPointerException, la vulnerabilidad está presente, mientras que si se presenta un error Page Not Found, CCS no es vulnerable.

Leer la biografía del autor  Ocultar la biografía del autor