Vulnerabilidad en execve() de los Kernel 2.4 de Linux

SeguridadVirus

Se ha identificado una vulnerabilidad en la versión 2.4 del kernel de Linux, que puede ser explotada potencialmente por un usuario local para conseguir información sensible.

La vulnerabilidad está provocada por un error en el llamada al sistema “execve()” cuando maneja el archivo descriptor para el destino ejecutable. Esto puede explotarse con éxito para leer ejecutables suid, donde el usuario solo tiene permisos de ejecución.

El disponer acceso de lectura sobre archivos ejecutables, es un problema que no debe ser pasado por alto. Pueden existir muchas implicaciones de seguridad al encontrarse información sensible en este tipo de archivos. Un claro ejemplo son los scripts perl y shell scripts, por lo que, como regla de seguridad hay que tener cuidado a la hora de programar y no situar datos sensibles en este tipo de archivos.

Junto con el anuncio de la vulnerabilidad se ha publicado una prueba de concepto disponible en: http://www.starzetz.com/paul/suiddmp.c

Leer la biografía del autor  Ocultar la biografía del autor