Vulnerabilidades en NSS de Sun Solaris y Java Enterprise System

SeguridadVirus

Sun ha reconocido dos vulnerabilidades en Sun Solaris y Sun Java Enterprise System que podrían ser explotadas por usuarios maliciosos para comprometer sistemas afectados.

Las dos vulnerabilidades se han localizado en Network Security Services (NSS):

* Un error de desbordamiento de entero a la hora de procesar mensajes de servidor SSLv2 puede ser explotado para provocar desbordamientos de búfer con un certificado con clave pública demasiado pequeña para cifrar el ‘Secreto Maestro’.

* Un error de desbordamiento de entero al procesar claves maestras de cliente SSLv2 puede ser explotado para provocar desbordamientos de búfer con parámetros malformados durante la negociación SSLv2.

La explotación con éxito de estas vulnerabilidades permitiría la ejecución de código arbitrario.

Dada la diversidad de versiones y plataformas afectadas se recomienda consultar el aviso de seguridad de Sun donde se detallan los parches publicados:

http://sunsolve.sun.com/search/document.do?assetkey=1-26-102856-1

Leer la biografía del autor  Ocultar la biografía del autor