Vulnerabilidades en OpenSolaris

CortafuegosSeguridad

Sun ha publicado una actualización de rdesktop que corrige tres vulnerabilidades en su proyecto de código abierto.

Las vulnerabilidades corregidas podrían permitir a un atacante remoto causar una denegación de servicio o ejecutar código arbitrario.

La primera vulnerabilidad está causada por un desbordamiento de enteros en la función iso_recv_msg (en iso.c). Un atacante remoto podría causar una denegación de servicio o ejecutar código arbitrario mediante una petición RDP (Remote Desktop Protocol) especialmente manipulada.

La segunda vulnerabilidad está causada por un desbordamiento de búfer en la función process_redirect_pdu (en rdp.c). Un atacante remoto podría provocar ejecutar código arbitrario mediante una petición de redirección RDP (Remote Desktop Protocol) especialmente manipulada.

La tercera vulnerabilidad está causada por entero sin signo en la función xrealloc (en rdesktop.c). Un atacante remoto podría ejecutar código arbitrario ser explotada por medio de parámetros desconocidos para causar un desbordamiento de búfer basado en heap.

Las vulnerabilidades afectan a sistemas X86 y SPARC hasta la compilación 85. En la actualidad Sun no ha publicado ninguna actualización para estos problemas.

Leer la biografía del autor  Ocultar la biografía del autor