Actualización de seguridad de GNUTLS

SeguridadVirus

El proyecto GNU publica actualizaciones de seguridad para su producto GNUTLS, que eliminan una vulnerabilidad que permite la denegación de servicio.

GNUTLS es una implementación del protocolo SSL/TLS alternativa al conocido OpenSSL. Ambas implementaciones son Open Source.

Las versiones de GNUTLS no actualizadas contienen una vulnerabilidad en la librería “libtasn1”, en la gestión de entradas DER (Distinguished Encoding Rules) incorrectas. Dicha vulnerabilidad permite provocar la caída del servicio que utilice la librería GNUTLS.

Hispasec recomienda a todos los administradores de sistemas con la librería GNUTLS instalada que actualicen a la versión 1.2.10 (rama estable) o 1.3.4 (rama experimental) de dicha librería, y la versión 0.2.18 de la librería “libtasn1”.

Se deberán reiniciar los programas que utilicen dichas librería de forma dinámica. Los programas que las utilicen de forma estática deben recompilarse/reenlazarse.

Leer la biografía del autor  Ocultar la biografía del autor