Denegación de Servicio en diversos productos Cisco

SeguridadVirus

Cisco ha anunciado que una cierta cantidad de sus productos se ven afectados por una vulnerabilidad en el procesamiento de mensajes IPSec IKE (Internet Key Exchange).

Un atacante que explote adecuadamente este problema provocaría denegaciones de servicio en los dispositivos afectados.

Los dispositivos Cisco que utilicen las siguientes versiones de software y estén configurados para usar IKE son vulnerables al problema:

* Cisco IOS versiones basadas en 12.2SXD, 12.3T, 12.4 y 12.4T

* Cisco PIX Firewall versiones anteriores a la 6.3(5)

* Cisco PIX Firewall/ASA versiones anteriores a la 7.0.1.4

* Cisco Firewall Services Module (FWSM) versiones anteriores a la 2.3(3)

* Cisco VPN 3000 Series Concentrators versiones anteriores a las 4.1(7)H y 4.7(2)B

* Cisco MDS Series SanOS versiones anteriores a la 2.1(2)

El problema se debe a que los dispositivos Cisco vulnerables no procesan adecuadamente paquetes IKE malformados, lo que provoca la reinicialización del proceso IKE en el caso de los Cisco MDS Series, y la del dispositivo en sí en el resto de productos afectados.

Las vulnerabilidades identificadas pueden ser fácilmente reproducibles utilizando la suite de pruebas para IKE OUSPG ‘PROTOS’.

La matriz de actualizaciones para las distintas versiones afectadas puede encontrarse en la notificación oficial de Cisco: http://www.cisco.com/warp/public/707/cisco-sa-20051114-ipsec.shtml

Leer la biografía del autor  Ocultar la biografía del autor