Denegación de servicio en SpamAssasin 3

SeguridadVirus

Se ha anunciado recientemente una vulnerabilidad en SpamAssasin (versiones de la 3.0.1 a la 3.0.3) que puede ser explotada por usuarios maliciosos remotos para provocar denegaciones de servicio en dicho programa y en el flujo normal del correo electrónico lícito.

SpamAssasin es una popular y eficaz herramienta open source para filtrado de correo no deseado (spam). Escrita en Perl, implementa un complejo sistema mixto de filtrado que incluye análisis de cabeceras y texto, filtrado bayesiano, listas de bloqueo DNS y bases de datos de filtrado colaborativo.

La vulnerabilidad descubierta se debe a un problema de SpamAssasin a la hora de procesar ciertas cabeceras cuando estas están construidas de forma maliciosa. Un atacante puede crear un mensaje de tal forma que el programa tardará una gran cantidad de tiempo en analizarlo. Repitiendo dicha operación, provocará una denegación de servicio efectiva, con lo que se puede entorpecer gravemente el acceso normal al correo electrónico de usuarios en sistemas que utilicen este programa.

Se recomienda actualizar a la versión 3.0.4, publicada el pasado día seis de este mismo mes, y disponible en la siguiente URL: http://spamassassin.apache.org/downloads.cgi?update=200506061100

Leer la biografía del autor  Ocultar la biografía del autor