Desbordamiento de memoria intermedia a través de ficheros MIDI en Winamp 5

SeguridadVirus

Se ha identificado una vulnerabilidad en Nullsoft Winamp que puede ser aprovechada por atacantes remotos para hacerse con un sistema vulnerable.

Winamp es seguramente el reproductor de archivos multimedia más famoso para plataformas Windows. Entre sus cualidades está el soportar múltiples formatos, ser ligero, aceptar infinidad de plug-ins y la posibilidad de descarga de versiones gratuitas.

El fallo se debe a un desbordamiento de memoria intermedia en la librería in_midi.dll, que no maneja adecuadamente cabeceras especialmente formadas de archivos MIDI. Esto podría ser aprovechado por atacantes para hacer que la aplicación deje de responder y posiblemente ejecutar código arbitrario. Para ello un usuario sólo tendría que visitar una página especialmente manipulada que intentase abrir un archivo en formato .mid o ejecutarlo directamente si el atacante lo envía de alguna forma.

Muchos usuarios no tienen conciencia de la importancia de actualizar todo el software que puedan tener instalado en su sistema, independientemente del sistema operativo. Winamp, cada cierto tiempo, sufre de un problema de desbordamiento de memoria en algún formato y puede convertirse en un origen de ataques al sistema tan peligroso como cualquier otro. En la mayoría de las ocasiones, sólo necesita de la ejecución de un archivo con la aplicación vulnerable para ser aprovechado. Su popularidad lo convierte en un jugoso objetivo para atacantes.

En este caso, además, existe código público capaz de aprovechar la vulnerabilidad. Se recomienda actualizar a Winamp 5.22 o posterior desde http://www.winamp.com/player/index.php

Leer la biografía del autor  Ocultar la biografía del autor