Desbordamiento de memoria intermedia en Red Hat Package Manager 4

SeguridadVirus

Se ha encontrado una vulnerabilidad en el Red Hat Package Manager por la que un atacante podría ejecutar código arbitrario en el sistema víctima.

Un atacante podría crear un paquete RPM especialmente manipulado que, al ser consultado por un usuario con ciertas locales especificadas (ru_RU.UTF-8, por ejemplo), provocaría un desbordamiento de memoria intermedia y permitiría la ejecución de código con los privilegios del usuario que ejecutara la consulta. Existe un parche a través de CVS https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=139715

Leer la biografía del autor  Ocultar la biografía del autor