El jailbreak del iPhone explota vulnerabilidades del terminal

CortafuegosEmpresasSeguridad
0 0

El nuevo jailbreak para el iPhone que ofrece libertad a sus usuarios para utilizar cualquier red instalar cualquier programa también permite explotar algunos fallos de los terminales.

Algunos investigadores de seguridad afirman que un fallo en JailbreakMe 2.0 puede aprovechar dos vulnerabilidades diferentes en dispositivos que estén ejecutando Apple iOS. Sin que se haya permitido su uso, los jailbreaks son programas que permiten a los usuarios ejecutar aplicaciones no autorizadas en un teléfono móvil.

La primera de estas vulnerabilidades de las que se aprovecha Jailbreak 2.0 está relacionada con el procesamiento de los datos Compact Font Format dentro de un documento PDF. El segundo, según explica Chaouki Bekrar, CEO de Vupen Security, es un fallo en el propio kernel que puede hacer que un atacante consiga privilegios y superar las limitaciones de la ‘sandbox’.

Un atacante podría explotar el primer fallo tentando de forma remota a los usuarios de un iPhone a visitar una página web maliciosa para redirigir después el navegador a un archivo PDF malicioso dependiendo del modelo y versión del dispositivo. Una vez hecho esto puede aprovecharse el fallo de kernel para tomar el control del dispositivo.

Los fallos afectan a todas las versiones de Apple iPhone, iPad e iPod.

Leer la biografía del autor  Ocultar la biografía del autor