Múltiples vulnerabilidades en Apple QuickTime 6 y 7

SeguridadVirus

Se ha anunciado la existencia de múltiples vulnerabilidades en Apple Quicktime.

Se ha anunciado la existencia de múltiples vulnerabilidades en Apple Quicktime, tanto en versiones Windows como para Mac OS X, y que pueden ser explotadas por usuarios maliciosos para provocar denegaciones de servicio o incluso, en última instancia, comprometer los sistemas afectados.

QuickTime es el reproductor de Apple para su tecnología para manejar vídeo, sonido, animaciones, gráficos y otros contenidos multimedia.

Las versiones afectadas son las 7 para Windows (anteriores a la 7.0.3) y las 6.5.2 y 7.0.1 para Mac OS X.

Las cuatro vulnerabilidades descubiertas son las siguientes:

* Un problema asociado con una cadena estilo ‘Pascal’ termina provocando una extensa copia de memoria, lo que puede ser explotado para provocar desbordamientos de entero si la víctima reproduce contenidos remotos maliciosos.

* La falta de un atributo de un archivo de vídeo es interpretado como una extensión, aunque la falta de extensión no es marcado como error. Esto lleva a un problema de referencia errónea de punteros, y con ello la posibilidad de una denegación de servicio si la víctima reproduce contenido remoto malicioso.

* Otro problema en el tratamiento de atributos de archivos de vídeo puede resultar en una extensa copia de memoria, explotable para provocar desbordamientos de entero.

* Un problema con el tratamiento de tamaños de variables durante el tratamiento de datos PICT puede ser explotado para provocar desbordamientos de búfer. Con ello se abre la puerta a la ejecución remota de código arbitrario en similares condiciones a los problemas anteriores.

Se recomienda actualizar a la versión 7.0.3, disponible en la siguiente dirección: http://www.apple.com/support/downloads/quicktime703.html

Leer la biografía del autor  Ocultar la biografía del autor