Vulnerabilidad por ataque symlink en Skype 1.1.0.20 para Linux

SeguridadVirus

Se ha descubierto una vulnerabilidad en la versión 1.1.0.20 de Skype para Linux que puede ser explotada por usuarios locales maliciosos para realizar escaladas de privilegios.

Skype es una popular aplicación para hablar a través de Internet con usuarios que posean el mismo software. Creado por los padres de Kazaa, está disponible para múltiples plataformas (Windows, Windows Pocket PC, diversas distribuciones Linux y Mac OS X).

La vulnerabilidad se debe a que el archivo temporal ‘/tmp/skype_profile.jpg’ se crea de forma insegura, lo que puede ser explotado por usuarios locales mediante ataques tipo enlace simbólico (symlink) para crear o sobreescribir archivos arbitrarios con los privilegios del usuario que esté ejecutando Skype.

Si bien el problema ha sido confirmado en la versión anteriormente nombrada (última disponible y publicada el pasado 5 de julio), no se descarta que versiones anteriores a la misma estén afectadas igualmente.

A la espera de la publicación de un parche oficial que solucione el problema, se recomienda restringir el acceso a los sistemas para que sean utilizados solamente por usuarios de confianza.

Leer la biografía del autor  Ocultar la biografía del autor