Descubierto desbordamiento de búfer en Zlib

SeguridadVirus

Se ha descubierto una vulnerabilidad en la librería zlib que podría ser explotada por usuarios maliciosos para provocar denegaciones de servicio o incluso comprometer la seguridad de un sistema que ejecute un programa que a su vez haga uso de versiones afectadas de esta librería (concretamente, versiones inferiores a la 1.2.2-r1).

Zlib es una librería de compresión sin pérdidas que es utilizada por una gran cantidad de programas.

El problema, descubierto por el equipo de auditoría de código de Gentoo, es un desbordamiento de búfer, localizado en ‘inftrees.c’. La vulnerabilidad se puede dar a la hora de procesar streams corruptos de datos comprimidos, lo que puede ser aprovechado por un atacante malicioso para provocar la caída del programa que usa esta librería, o incluso para ejecutar código arbitrario con los privilegios de la aplicación vulnerable.

Diversas plataformas (Gentoo en sí, Debian, FreeBSD, SuSE, Red Hat, etc.) han publicado ya actualizaciones para solventar el problema. Se recomienda actualizar a la mayor brevedad posible, y posteriormente recompilar las aplicaciones que puedan verse afectadas por este problema.

Aunque oficialmente aun no ha salido el parche en la página web de zlib, desde otras distribuciones como Gentoo se facilita un diff.

Leer la biografía del autor  Ocultar la biografía del autor